Download AmigaLive 0.97 with FS-UAE 2.9.7 for Windows

Although FS-UAE is Cross-Platform compatible, it is not Cross-Version compatible.
All connecting players must have the same major FS-UAE version (2.9.x).

*Windows XP users are required to install Microsoft .Net Framework 3.5 Service Pack 1